栈模拟
实现一个栈,栈初始为空,支持四种操作:
push x
– 向栈顶插入一个数 xx;pop
– 从栈顶弹出一个数;empty
– 判断栈是否为空;query
– 查询栈顶元素。
现在要对栈进行 MM 个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。
输入格式
第一行包含整数 MM,表示操作次数。
接下来 MM 行,每行包含一个操作命令,操作命令为 push x
,pop
,empty
,query
中的一种。
输出格式
对于每个 empty
和 query
操作都要输出一个查询结果,每个结果占一行。
其中,empty
操作的查询结果为 YES
或 NO
,query
操作的查询结果为一个整数,表示栈顶元素的值。
数据范围
1≤M≤1000001≤M≤100000,
1≤x≤1091≤x≤109
所有操作保证合法。
输入样例:
10
push 5
query
push 6
pop
query
pop
empty
push 4
query
empty
输出样例:
5
5
YES
4
NO
import java.util.*;
public class Main {
static int N = 100010;
static int[] stk = new int[N];
static int top;
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int m = sc.nextInt();
while(m-- > 0) {
String ops = sc.next();
if(ops.equals("push")) {
int x = sc.nextInt();
stk[top++] = x;
} else if(ops.equals("pop")) {
top--;
} else if(ops.equals("empty")) {
if(top == 0) {
System.out.println("YES");
} else {
System.out.println("NO");
}
} else {
System.out.println(stk[top - 1]);
}
}
}
}
队列模拟
实现一个队列,队列初始为空,支持四种操作:
push x
– 向队尾插入一个数 xx;pop
– 从队头弹出一个数;empty
– 判断队列是否为空;query
– 查询队头元素。
现在要对队列进行 MM 个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。
输入格式
第一行包含整数 MM,表示操作次数。
接下来 MM 行,每行包含一个操作命令,操作命令为 push x
,pop
,empty
,query
中的一种。
输出格式
对于每个 empty
和 query
操作都要输出一个查询结果,每个结果占一行。
其中,empty
操作的查询结果为 YES
或 NO
,query
操作的查询结果为一个整数,表示队头元素的值。
数据范围
1≤M≤1000001≤M≤100000,
1≤x≤1091≤x≤109,
所有操作保证合法。
输入样例:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
NO
6
YES
4
import java.util.*;
public class Main {
static int N = 100010;
static int[] q = new int[N];
static int hh = 0, tt = -1;
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int m = sc.nextInt();
while(m-- > 0) {
String ops = sc.next();
if(ops.equals("push")) {
int x = sc.nextInt();
q[++tt] = x;
} else if(ops.equals("pop")) {
++hh;
} else if(ops.equals("empty")) {
if(hh <= tt) {
System.out.println("NO");
} else {
System.out.println("YES");
}
} else {
System.out.println(q[hh]);
}
}
}
}
评论区